• Wichtig für neu Mitglieder

    Aktuell haben wir das Problem dass Mail an GoogleMail nicht ankommen. Wenn du dich registrien möchtest gib bitte keine GoogleMail an.

    Euer Forenteam

  • Herzlich Willkommen bei den Konsolen-Senioren!

    Wir sind eine deutschsprachige Community, die Spielern über 30 Jahren seit 2007 ein Zuhause im Internet bietet, in dem sie sich mit gleichgesinnten und erwachsenen Spielern über ihr Hobby austauschen und zu gemeinsamen Aktivitäten verabreden können.

    Entstanden aus den Xbox-Senioren (früher: XBL-Senioren) und den PSN-Senioren bieten wir mittlerweile eine konsolenübergreifende Diskussions- und Verabredungsplattform, bei der das respektvolle Miteinander und der Spaß am Hobby im Vordergrund stehen.

    Neben konsolenspezifischen Unterforen und Multiplattform-Spielethreads bieten wir auch eine Retro-Ecke und einen Bereich, in dem sich für die immer größer werdende Anzahl Spielen, die Cross-Plattform-Play unterstützen, verabredet werden kann.

    Egal, ob Du einfach nur über Spiele diskutieren möchtest, Dich mit anderen Spielern verabredet willst oder einfach nur Deine Spielerfahrungen mit anderen teilen möchtest, bist Du bei uns herzlich willkommen.

    Natürlich kannst Du auch einfach weiter passiv bei uns mitlesen, aber warum schnappst Du Dir nicht einfach Deine Tastatur, registrierst Dich bei uns und gestaltest die Community durch Deine Teilnahme aktiv mit?

    Wir freuen uns auf Dich!

Technik für Noobs, only for Dimo und Stosi

Dimo2006

Frührentner
Ansonsten kannste ja das Dokument hier durchlesen:
Quelle: MS - Download Xbox One Technical Details from Official Microsoft Download Center

Du könntest das auch selbst finden, wenn Du mal richtig suchen würdest .... :shame:


Xbox One
Technical information on P2P Networking Behavior
Version 1.0
Last updated: October 6, 2013

Many gaming and app scenarios on Xbox® One rely on low-latency peer-to-peer (P2P) networking capabilities. The platform for these capabilities leverages IPv6, Teredo, and IPsec Internet standards.
The primary purpose of this document is provide technical information on Xbox One P2P behavior, so that network operators and network equipment manufacturers can address possible configuration issues and ensure end-users have a positive experience.
IPv6 and IPsec

One of the many benefits of IPv6 is simplified connectivity between peers on the Internet. Xbox One takes advantage of this, and IPv6 may be attempted as a connectivity mechanism between peers if available.
Proper authentication of peers and integrity of data traffic is critical to fair, safe gaming. To this purpose, transport-mode IPsec is used for most P2P traffic in most games, with IKEv2 used for security setup (RFC 5996).
RFC 6092 provides useful guidelines on the security and filtering behavior for IPv6 customer premise equipment.

  • Allow IPsec and IKE
    • In general P2P traffic will be used with IPsec with the encapsulating security payload (ESP) option. Section 3.2.4 provides guidelines on interacting with IPsec.
      • “The Internet Protocol security (IPsec) suite offers greater flexibility and better overall security than the simple security of stateful packet filtering at network perimeters. Therefore, residential IPv6 gateways need not prohibit IPsec traffic flows.”
      • Ensure that you are not filtering inbound IKE traffic – which is UDP on port 500 and port 4500.
  • Enable transparent operation
    • We also note Recommendation 49. This may be relevant for users troubleshooting connectivity issues or who in general desire transparent operation.
      • “Internet gateways with IPv6 simple security capabilities MUST provide an easily selected configuration option that permits a "transparent mode" of operation that forwards all unsolicited flows regardless of forwarding direction, i.e., not to use the IPv6 simple security capabilities of the gateway. The transparent mode of operation MAY be the default configuration.”
Teredo

IPv6 is not yet globally available in the consumer Internet market. For the majority of users, Teredo will be used to provide P2P connectivity. Teredo is an IPv6 transition technology that provides Teredo clients a tunneled IPv6 address for P2P connectivity.
Teredo can also be used to provide connectivity to hosts on the native IPv6 Internet, using a Teredo relay. However, that capability will be rarely used by Xbox One.
The Teredo implementation on Xbox One behaves similar to that on Windows® 7 and 8.1. The design of Teredo is described in RFC 4380, RFC 5991, and RFC 6081. We have additional documentation on Teredo available on TechNet.
Even for users that do have native IPv6 – Teredo will be used to interact with IPv4-only peers, or in cases where IPv6 connectivity between peers is not functioning. In general, Xbox One will dynamically assess and use the best available connectivity method (Native IPv6, Teredo, and even IPv4). The implementation is similar in sprit to RFC 6555.
For that reason, it is important for all interested network operators to understand Teredo operating requirements. Xbox One does not support operating on an IPv6-only network because of the need to reliably interoperate with nodes on IPv4-only networks.

  • Allow UDP
    • Teredo uses UDP to create port mappings in NAT equipment and to communicate with Teredo peers. RFC 4787 and RFC 6888 provide recommendations on UDP behavior of network equipment. Sections 4-6 of RFC 4787 are especially relevant to network operators and equipment vendors.
  • Configure open NATs, avoid symmetric
    • RFC 6081, Section 3, provides a connectivity matrix for Teredo. In general, cone, address restricted, and port restricted NATs, work fine with Teredo. Networks that block UDP traffic will not support P2P gaming. The more “open” a NAT, the more likely the user will be able to communicate directly with others, and in general the better experience the user will have.
  • Avoid requiring frequent keep-alives
    • Even with networks that support UDP, if the keep-alive interval for UDP port mappings is less than 60 seconds – then connectivity issues may arise for end-users.
    • RFC 4787 recommends 5 minutes.
    • Teredo will refresh port mappings approximately every 30 seconds.
  • Support hairpinning
    • Networks should support hairpinning (Section 6 of RFC 4787), to allow multiple Teredo clients on the same network to communicate with one another. Compliance with this recommendation is especially important for network operators who are deploying carrier-grade NAT functionally.
  • Don’t block encapsulated IPsec
    • With Teredo, IPv6 packets are encapsulated in an IPv4 UDP datagram. These IPv6 packets will be secured with IPsec, as described earlier.
    • If for any reason a network administrator performs de-encapsulation of Teredo traffic for inspection purposes, they should allow IPsec traffic, and generally follow the guidelines provided earlier for IPv6 security.
Teredo Ports

Teredo clients will initiate contact with a Teredo server that is listening on port 3544, using UDP, as part of the Teredo client qualification procedure. The local port is from the dynamic range. Enabling port forwarding for port 3544 is not necessary or helpful.
For actual P2P traffic, Teredo will attempt to use local port 3074, again with UDP. This is the same port that Xbox 360 uses. Enabling inbound communication to this port using explicit port forwarding rules is helpful, though rarely required. Teredo will attempt to use UPnP and UDP messages to ensure inbound connectivity to the Teredo port.
If 3074 is unavailable, a local port from the dynamic port range (49152-65535) will be used – and again Teredo will attempt to automatically provide inbound connectivity without the need for explicit port forwarding rules.
Xbox One IPv4 P2P traffic may be distinguished from other types of IPv4 traffic by identifying:

  1. The typical usage of port 3074 in a UDP datagram.
  2. That the traffic is embedding Teredo packets.
    1. One can identify this by looking for the four bytes for the 2001:0000 prefix in the IPv6 header.
  3. That the embedded Teredo packets use an ESP header.
We expect this combination should be fairly unique to Xbox One. Items 2 and 3 can be used to distinguish Xbox One traffic from Xbox 360 traffic, and items 1 and 3 can be used to distinguish Xbox One traffic from common Teredo traffic. We recommend network administrators treat Xbox One and Xbox 360 traffic similarly.

Figure 1 - Packet format with Teredo and IPsec, as used by Xbox One.
Monitoring and Support

If authorized by the end-user, Microsoft® collects telemetry on the performance and reliability of P2P networking on Xbox One. This information will be used to engage with network operators if geographically specific issues are found.
Xbox One includes a network troubleshooter, which can inform the user if their network is not compliant with the above requirements.
Network operators and equipment vendors can address questions and concerns to xboxteredo@microsoft.com.
 
G

Gelöschtes Mitglied 127

Guest
Da keiner hier im Forum weiss worum es geht wäre es nicht schlecht wenn ihr per PN weitermacht.
 

Stosi

Pförtner des Altenheims
Nööööö.... kein Normalsterblicher hat zu Hause einen tranparenten Proxy laufen, das ist mehr etwas für
Firmen Netzwerke, daher muss die One damit nicht umgehen können.

Ach Dimo!

Ich bin ja auch nicht "normal"!
Ich will einen Router der sich bei 100Mbit WAN/LAN langweilt und nicht bei 20Mbit die Backen dicht macht.
Einen der in Echtzeit nach Viren scannt und sonstige Auffälligkeiten im Datenstream erkennen kann.
Der nen Adblocker hat und diverse andere Möglichkeiten, sei es ein Mailsammeldienst, ne Ip-Telefonanlage oder TS3.
Ein neu endecktes Hobby halt! Eines ist mir aber unklar, warum dürfen Firmen keine One betreiben?

Zumal Du erst mal nachweisen musst, das der Fehler bei der One und nicht bei Deinem Routergefrickel liegt :silly::ugly:

Ob man nun eine Linux Distri als gefrickel bezeichnen kann, ist reine Ansichtssache, manche finden auch Äpfel toll.

Probleme bestehen zumindest nur mit der One.
PS3 z.B. zeigte beim Netzwerktest alles brav an. Nattyp 2, Upload, Download etc., die One nicht.
Tests der One laufen wohl nicht lokal, sondern in der Cloud oder sonstwo und die One bekommt das
Ergebnis dann per http request mit dem gefälschten Header. Nur will die kleine Box das Paket dann nicht haben.

Was machen die Leute, die einen Zwangsproxy des Providers nutzen müssen?
Ich finde es schon sehr merkwürdig, dass die One nicht mit Proxys umgehen kann.
Jedenfalls haben 360, PS3, Gaming-PC und sonstige internetfähige Geräte keine Probleme.

Außerdem könnte Dein "Zugespamme" einfach nur die Abfrage sein, ob Du noch da bist. Wenn Deine Kiste dann irgendwann nicht mehr antwortet => Verbindung kappen und gut ist...

Das zugespamme von den anderen Partyteilnehmer ist ICMP(3) Destination Unreachable.
Dies will mir irgendwie nicht in den Kopf. Warum bekomme ich bei funktionierender Party
ein Destination unreachable zurück bzw. überhaupt und dies auch von dem Partyhost?
Antwortet die Fritzbox automatisch mit Destination unreachable?
Was ist, wenn bei dem Partyhost "Ping aus dem Internet ignorieren" aktiv ist?
Sind dann keine Partys möglich oder fliegt man dann nach einiger Zeit raus?

Schlußfolgerung, alle Router sind Schuld. :ugly:
 
Zuletzt bearbeitet:

Stosi

Pförtner des Altenheims
Da keiner hier im Forum weiss worum es geht wäre es nicht schlecht wenn ihr per PN weitermacht.

Hä?
Sorry, aber gehts noch?

Ich und Dimo wissen es, reicht dies nicht? Oder gehören wir nicht zum Forum?
Erst sollen wir uns aus anderen Threads zurückziehen, nun machen wir einen eigenen und der ist auch nicht in Ordnung?
Hast Du schon einmal PN's mit langem Text bekommen und in dem Minifenster geantwortet inkl. Quotes?

Also langsam weiß ich auch nicht mehr...... wenn ihr nicht wollt das man hier Beiträge erstellt oder mich (uns) los werden wollt,
dann geht es auch einfacher.
 

X30 Trucase

Moderator
Team
Da keiner hier im Forum weiss worum es geht wäre es nicht schlecht wenn ihr per PN weitermacht.

Ich sehe das nicht so.
Ich finde es gerade gut, dass es hier diesen Technik-Thread gibt, er ist ja sogar im korrekten Bereich angelegt.
Ich vote dafür, lasst die beiden auf jeden Fall hier weitermachen, da kann sich manch "Normalsterblicher" noch nen Scheibchen von abschneiden.
:top:

Und es hieß ja schon im Eingangsbeitrag: Das Postfach für PNs ist voll. Wer daran wohl schuld ist? :fettes Grinsen:

Der Beitrag soll übrigens nicht das Trolling begünstigen. Wenn die Threadersteller dies als störend empfinden, darf dieser Beitrag gern auf ihren Wunsch hin gelöscht werden.
 
G

Gelöschtes Mitglied 127

Guest
Okay, dann macht halt weiter. [MENTION=898]Stosi[/MENTION]: Ich finde es immer wieder toll wie einige hier gute Umgangsformen pflegen. :shame:
 
Zuletzt bearbeitet von einem Moderator:

Stosi

Pförtner des Altenheims
Ich sehe das nicht so.

Danke!

Und es hieß ja schon im Eingangsbeitrag: Das Postfach für PNs ist voll. Wer daran wohl schuld ist? :fettes Grinsen:

Ich nicht, war erst bei 7 oder so!

Der Beitrag soll übrigens nicht das Trolling begünstigen.

Lass sie doch! :baby tap tap:

Okay, dann macht halt weiter. @Stosi: Ich finde es immer wieder toll wie einige hier gute Umgangsformen pflegen. :shame:

Danke!
Habe mich doch im Vorfeld schon entschuldigt.
Also noch ein Sorry! Ist mir halt so rausgerutscht.

Man wird hier seit Tagen hin und her geschubst und dann kommst du mit nem Tritt in den Hintern.
 
Zuletzt bearbeitet:

Dimo2006

Frührentner
Ach Dimo!
Eines ist mir aber unklar, warum dürfen Firmen keine One betreiben?

Werter Stosi,

in Firmennetzen sollen die Damen und Herren arbeiten und nicht spielen oder sich den multimedialen Ergüssen der
XBone hingeben. Einigen Firmen sind schon die Smart-TV's zuviel. Ich gebe zu, dass in meiner Firma schon mal
bei Übernacht-Backups mit der Plastik-Gitarre und Rock Band so manche Stunde musikalisch begangen worden ist,
dies ist aber bei den anderen Firmen eher selten... :zwinker:


Ob man nun eine Linux Distri als gefrickel bezeichnen kann, ist reine Ansichtssache, manche finden auch Äpfel toll.

Es ist Gefrickel, da nunmehr selbstgestrickt ... und Äpfel sind zum Essen da. Der Rest ist Fallobst :cool:


Probleme bestehen zumindest nur mit der One.
PS3 z.B. zeigte beim Netzwerktest alles brav an. Nattyp 2, Upload, Download etc., die One nicht.

PS3 ? Habe ich auch irgendwo in der Ecke liegen... vielleicht 100 Stunden auf der Uhr... Du hast
doch auch ne Xbox 360? Ich denke, der Vergleich damit wäre besser gewesen.

Tests der One laufen wohl nicht lokal, sondern in der Cloud oder sonstwo und die One bekommt das
Ergebnis dann per http request mit dem gefälschten Header. Nur will die kleine Box das Paket dann nicht haben.

Ist möglich... Wenn Du meinen vorherigen Post gelesen hast, dann weißt Du auch, dass die Xbone einen
IPSEC Tunnel aufbaut und dabei via IP6 mit dem Rest der Bande kommuniziert... dort wird dann auch
Teredo eingesetzt.


Was machen die Leute, die einen Zwangsproxy des Providers nutzen müssen?
Ich finde es schon sehr merkwürdig, dass die One nicht mit Proxys umgehen kann.
Jedenfalls haben 360, PS3, Gaming-PC und sonstige internetfähige Geräte keine Probleme.

Ja nee... so einfach ist das dann doch nicht. Zum einen beschreibt mein vorheriger Post genau, worauf die
Provider achten sollen, damit die ONE bei denen auch läuft. Zum anderen laufen die andere Boxen gerade im
3G Netz eben nicht unbedingt sauber und das ist nicht immer der Latenz geschuldet.

Das zugespamme von den anderen Partyteilnehmer ist ICMP(3) Destination Unreachable.
Dies will mir irgendwie nicht in den Kopf. Warum bekomme ich bei funktionierender Party
ein Destination unreachable zurück bzw. überhaupt und dies auch von dem Partyhost?
Antwortet die Fritzbox automatisch mit Destination unreachable?
Was ist, wenn bei dem Partyhost "Ping aus dem Internet ignorieren" aktiv ist?
Sind dann keine Partys möglich oder fliegt man dann nach einiger Zeit raus?

Eine Party ist eine p2p Verbindung (wie im vorherigen Post beschrieben). Diese ist im Prinzip ein IPV6 VPN Tunnel.
Dein Ping wird sicherlich eine weitere Maßnahme für den Fortbestand der Verbindung sein, man nutzt einen Ping
auch gerne dazu, um eine eigene Verbindung offen zu halten, bevor bspw. die Firewall den Port wieder zumacht.
Es kann aber die Testlogik von MS sein:

"If authorized by the end-user, Microsoft® collects telemetry on the performance and reliability of P2P networking on Xbox One. This information will be used to engage with network operators if geographically specific issues are found."


Schlußfolgerung, alle Router sind Schuld. :ugly:

Genau.... warte mal ab, bis wir alle auf IPV6 umsteigen... ich glaube, dann gehe ich vorzeitig in Rente !
 

Stosi

Pförtner des Altenheims
Huh!

Es ist Gefrickel, da nunmehr selbstgestrickt ...

Nö, abgeänderte Config ist doch kein Gefrickel.


PS3 ? Habe ich auch irgendwo in der Ecke liegen... vielleicht 100 Stunden auf der Uhr... Du hast
doch auch ne Xbox 360? Ich denke, der Vergleich damit wäre besser gewesen.

Die 360 hat doch gar keine erweiterten Netzwerktest. Der normal Test lief ohne Probleme durch.
Sonst kann man doch nur rumpingen bzw. tracerouten mit der 360. Die One hat sogar nen erweiterten NAT-Test.
Mir erzählt die One immer: Ihr Netzwerk befindet sich nicht hinter einem Cone NAT.

Ist möglich... Wenn Du meinen vorherigen Post gelesen hast, dann weißt Du auch, dass die Xbone einen
IPSEC Tunnel aufbaut und dabei via IP6 mit dem Rest der Bande kommuniziert... dort wird dann auch
Teredo eingesetzt.

Eben nicht, eventuell mal selbst die offenen Verbindungen ansehen?
Ach! Ganz vergessen, du hast ja ne Fritzbox.:fettes Grinsen:
Verweise hierbei auch noch auf die C'T #9, Router-Disaster..... muhaahaha muhaaha!


Eine Party ist eine p2p Verbindung (wie im vorherigen Post beschrieben). Diese ist im Prinzip ein IPV6 VPN Tunnel.
Dein Ping wird sicherlich eine weitere Maßnahme für den Fortbestand der Verbindung sein, man nutzt einen Ping
auch gerne dazu, um eine eigene Verbindung offen zu halten, bevor bspw. die Firewall den Port wieder zumacht.
Es kann aber die Testlogik von MS sein:

"If authorized by the end-user, Microsoft® collects telemetry on the performance and reliability of P2P networking on Xbox One. This information will be used to engage with network operators if geographically specific issues are found."

Hmmm, keine Ahnung.
Eventuell pingt auch jeder, jeden an? So nach dem Motto, wer hat offenen Nat?
Macht aber irgendwie auch kein Sinn. Die ICMP-Dinger sind erst seit der One.


Genau.... warte mal ab, bis wir alle auf IPV6 umsteigen... ich glaube, dann gehe ich vorzeitig in Rente !


Hehe!
Da zitiere ich mal dein MS-Zitat:

Xbox One does not support operating on an IPv6-only network...
 
Zuletzt bearbeitet:

Dimo2006

Frührentner
Eben nicht, eventuell mal selbst die offenen Verbindungen ansehen?
Ach! Ganz vergessen, du hast ja ne Fritzbox.:fettes Grinsen:
Verweise hierbei auch noch auf die C'T #9, Router-Disaster..... muhaahaha muhaaha!

Also wirklich: Ich glaube den Machern der XBOX ONE eher, das die Verbindung auf IPV6
basiert bzw. durch Teredo getunnelt wird. Ansonsten hätte es mit der FritzBox keine Probleme
gegeben, als das Teredo-Protokoll nicht durchgelassen worden ist... Btw. ich habe nicht nur
eine FritzBox im Bestand... das kannste mir glauben... :fettes Grinsen: Kannst ja mal Teredo und Co nicht
durchlassen. Bevor Du das dann machst: einmal den MS Post lesen und VERSTEHEN... :Teufel:

Hehe!
Da zitiere ich mal dein MS-Zitat: Xbox One does not support operating on an IPv6-only network...


Na, Stosi... wenn dann Zitat, dann auch bis zum bitteren Ende:

"Xbox One does not support operating on an IPv6-onlynetwork because of the need to reliably interoperate with nodes on IPv4-only networks. "


Bestätigt doch lediglich die Aussagen, dass man Teredo nutzt, um eben auch mit den Kisten in Kontakt treten zu können, die nur IPV4 haben. Da:

"IPv6 is not yet globally available in the consumer Internet market. For the majority of users, Teredo will be used to provide P2P connectivity. Teredo is an IPv6 transition technology that provides Teredo clients a tunneled IPv6 address for P2P connectivity."


Zudem lassen sich IP VP6 Header in den Teredo Datenströmen erkennen:


"Xbox One IPv4 P2P traffic may be distinguished from other types of IPv4 traffic by identifying: That the traffic is embedding Teredo packets. One can identify this by looking for the four bytes for the 2001:0000 prefix in the IPv6 header."

Das macht Teredo de facto zu einem VPN-Tunnel. Zumal die Daten durch IPSEC verschlüsselt werden. Das macht Deine Frickelrouter-Firewall dann obsolet, wenn Deine XboxOne in Deinem internen Netz schalten und walten darf, wie sie will, da sie durch den Teredo Tunnel Deine Firewall getunnelt hat...
 
Oben